Register

PF2e Exploit Vulnerability

An Add-on Module for Foundry Virtual Tabletop

Author: StraySurvive Project Source: Project URL Versions 11+ (Verified 11.313) Last Updated 3 months, 2 weeks ago

PF2e Exploit Vulnerability

Improvement for Thaumaturge Exploit Vulnerability

This project is a carryover until the pf2e system for Foundry VTT implements Thaumaturge Exploit Vulnerability

IMPORTANT!!!

Make sure actors are assigned to players!
IWR must be turned on in the PF2e Core Automation Settings or damage will not be applied properly
A thaumaturge's Esoteric Lore entry must be listed as Esoteric Lore, Esoteric, or Lore Esoteric or it will not work

Functionality

Feats

 

  1. Import the Exploit Vulnerability macro from the "MySurvive's Thaumaturge Macros" compendium and give the player the proper permissions to execute the macro.
  2. The player should drag the macro onto their hotbar.
  3. The player must target exactly one enemy on the screen, then run the macro.
  4. The macro will roll the Esoteric Lore check and compare it to the target's level DC. It will determine the degree of success and automate the effects.

Critical Success: The player will receive a dialog window that provides all weaknesses, resistances, and immunities, if there are any. They will be able to choose whether they want to exploit a personal antithesis or a mortal weakness, providing them with values at a quick glance to show which is higher. Making a choice will apply an effect to them (Exploit Mortal Weakness or Exploit Personal Antithesis) and to the enemy (Mortal Weakness Effect (SOURCE NAME) or Personal Antithesis Effect (SOURCE NAME)).

Success: The player will receive a dialog window that provides the highest weakness of the target, if there is one. Like on a critical success, it will provide values at a quick glance that will show which is higher and apply appropriate effects based on choice in the dialog.

Failure: The Personal Antithesis effects will be added tot he player and the target.

Critical Failure: A flat-footed effect will be applied to the player that will drop off at the beginning of their next turn.

 

  1. In the event that the player chooses to exploit a Mortal Weakness (or the sympathetic weakness feat), there is another macro for GMs to use that will apply the Mortal Weakness effect to additional targets that fit the criteria "enemies of the exact same type." Since Paizo doesn't explicitly state what qualifies as a creature type, or "exact same type," this has been provided in a macro for GMs to use at their discretion. However, the default behavior is for the module to apply the effect to all targets of the same name in the scene. Simply target the actors that should have the effect (I recommend using shift+T to target multiple targets), select the thaumaturge that created the effect, and then run the "Force EV" macro from the "MySurvive's Thaumaturge Macros" compendium.

     

  2. When the thaumaturge attacks, the value of the exploit vulnerability will only be added to their attacks, taking IWR into account. 


Relevant actions have buttons on their chat cards to run their respective macros (currently only Exploit Vulnerability, Share Weakness, and Cursed Effigy). 

Settings

There are settings to turn on/off the

Supported Game Systems

  1. Pathfinder Second Edition

    Latest Version: Version 5.13.6 Last Updated 3 months, 1 week ago

Categories

Available Versions

  1. Version 0.13.1

    Compatibility: 11+ (Verified 11.313) Installation Link: Manifest URL Update Notes: Read Notes
  2. Version 0.13.0

    Compatibility: 11+ (Verified 11.313) Installation Link: Manifest URL Update Notes: Read Notes
  3. Version 0.12.4

    Compatibility: 11+ (Verified 11.313) Installation Link: Manifest URL Update Notes: Read Notes
  4. Version 0.12.3

    Compatibility: 11+ (Verified 11.313) Installation Link: Manifest URL Update Notes: Read Notes
  5. Version 0.12.2

    Compatibility: 11+ (Verified 11.313) Installation Link: Manifest URL Update Notes: Read Notes
  6. Version 0.12.1

    Compatibility: 11+ (Verified 11) Installation Link: Manifest URL Update Notes: Read Notes
  7. Version 0.12.0

    Compatibility: 11+ (Verified 11) Installation Link: Manifest URL Update Notes: Read Notes
  8. Version 0.11.10

    Compatibility: 11+ (Verified 11) Installation Link: Manifest URL Update Notes: Read Notes
  9. Version 0.10.9

    Compatibility: 10 - 10 (Verified 10) Installation Link: Manifest URL Update Notes: Read Notes
  10. Version 0.9.8

    Compatibility: 10 - 10 (Verified 10) Installation Link: Manifest URL Update Notes: Read Notes