Register

Loot populater NPC | 5e

A Module for Foundry Virtual Tabletop

Author: JackPrince Project Source: Project URL Version 8 Last Updated 3 weeks, 4 days ago

Loot Populater NPC | 5E

This module allows you to enable automatic population of loot on monsters and NPCs in 5e.

The module is heavily inspired by LootSheetNPC5e and also is only really useful when using this in tandem.
As LootSheetNPC5e adds the capability and permission handling for players to actually loot items from token/actors.

Also recommended is the use of better rolltables, it will greatly improve you experience when working with rolltables.

Features


Above behavior is especially usefull when you have macros that convert a monster to a lootsheet after and encounter.
These macros often expect the sheet not be a npclootsheet when clicking the macro.

Settings screenshots (taken in FoundryVTT v0.7.9 and 0.8.6)

(i) Click the screenshot to open bigger version

Example of filled inventory

On the left is the sheet of a token that was droped on the scene. The right sheet is the original sheet directly opened from the actor.

image

Compatibility:

Installation Instructions

To install a module, follow these instructions:

  1. Start FVTT and browse to the Game Modules tab in the Configuration and Setup menu
  2. Select the Install Module button and enter the following URL: https://raw.githubusercontent.com/DanielBoettner/fvtt-loot-populator-npc-5e/master/module.json
  3. Click Install and wait for installation to complete

Feedback

If you have any suggestions or feedback, please submit an issue on GitHub or contact me on Discord (JackPrince#0494).

Supported Game Systems

  1. DnD5e

    Latest Version: Version 2.0.3 Last Updated 3 weeks, 4 days ago

Categories

Available Versions

  1. Version 0.0.3.1

    Compatible Foundry Versions: 0.7.9 - 0.7.10 Installation Link: Manifest URL Update Notes: Read Notes
  2. Version 0.2.2

    Compatible Foundry Versions: 0.8.5 - 0.8.8 Installation Link: Manifest URL Update Notes: Read Notes
  3. Version 0.3.1

    Compatible Foundry Versions: 0.8.5 - 0.8.9 Installation Link: Manifest URL Update Notes: Read Notes