Package Description

A module to add support for ME5e, a futuristic sci-fi setting, to be more easily integrated into a 5e world.



Required Game Systems

  1. DnD5e Latest Version: Version 1.2.4 Last Updated 3 months, 2 weeks ago

Tagged Categories

  1. Content Packs
  2. Actor and Item Sheets

Available Versions

  1. Version v1.0

  2. Version v1.1

  3. Version v1.2

  4. Version v1.3

  5. Version v1.4

  6. Version v1.6

  7. Version v1.7

  8. Version v1.7.1

  9. Version v1.7.4

  10. Version v1.8.1

  11. Version v1.9.0